Issue on Address services
Incident Report for Woosmap
Postmortem

Issue:
- Customers requesting /autocomplete and /geocode endpoints of Address API received 200 http code with no content and “UNKNOWN_ERROR” status.

Origin:
- A Woosmap internal process generating unexpected rate limits has been identified as the cause of this issue.

Mitigation actions:
- A fix has been done and deployed to remove the unsuitable rate limit process. The Services have been restored and are fully operational this then.

Improvements to be made:
- Large scale analysis on error codes and response status on Woosmap services
- More detailed monitoring and logs to engage quicker mitigation actions

Posted Jun 16, 2021 - 18:36 CEST

Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 11:15 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2021 - 10:45 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 16, 2021 - 10:30 CEST
Update
Issue detected
Posted Jun 16, 2021 - 10:00 CEST
Investigating
Random "Internal Error" messages when requesting API on the /autocomplete or /geocode endpoints.
Service partially impacted.
Posted Jun 16, 2021 - 09:45 CEST
This incident affected: Woosmap Address API.