Post-mortem: Localities API Incident – June 30th, 2025
Between 15:52 and 18:10 UTC, the Localities API experienced significant degradation, with high latency and elevated error rates. The issue was linked to unexpected behavior within our infrastructure. Service was progressively restored and returned to normal at 18:20 UTC. We’ve since implemented targeted improvements to prevent similar issues and strengthen overall resilience.
Posted Jul 01, 2025 - 17:52 CEST
Monitoring
The situation has been stable for the past 20 minutes and the service is now back to normal. We’ll continue to monitor closely to ensure everything remains fully operational.
We’ll share a post-mortem shortly. Thanks again for your understanding throughout the incident.
Posted Jun 30, 2025 - 20:33 CEST
Update
From partial outage to Operational
We’ve observed a noticeable improvement and are continuing to monitor the situation closely. Our investigations and validations are still ongoing to ensure stability.
Posted Jun 30, 2025 - 20:21 CEST
Update
We’ve observed a noticeable improvement and are continuing to monitor the situation closely. Our investigations and validations are still ongoing to ensure stability.
Posted Jun 30, 2025 - 20:20 CEST
Update
We’re continuing to monitor the system closely and are reviewing the results of our recent actions. Investigations are progressing as planned. Thank you for your continued patience.
Posted Jun 30, 2025 - 20:06 CEST
Update
We’re making progress and currently reviewing the effects of the potential fix we identified. The issue is still under investigation and not resolved yet.
Thank you for your patience and understanding.
Posted Jun 30, 2025 - 19:50 CEST
Update
We have identified a possible patch. We’ll share more updates shortly.
Sorry for the inconvenience.
Posted Jun 30, 2025 - 19:33 CEST
Update
From degraded performances to partial outage
Posted Jun 30, 2025 - 18:16 CEST
Update
We are continuing to investigate this issue.
Observations: - Latency on Woosmap Localities API - Some requests on Woosmap Localities API may have generated 5xx