Investigating Platform Performance Issues

Incident Report for Woosmap

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 16:49 CEST

Update

We faced a spike of requests on localities api, we scaled the service accordingly to face the the spike.
Posted Oct 08, 2025 - 16:49 CEST

Investigating

We are currently investigating performance issues affecting the Woosmap Platform. Our team is working to identify the cause and restore normal service as quickly as possible. Updates will follow here. We apologize for the inconvenience.
Posted Oct 08, 2025 - 16:28 CEST
This incident affected: Woosmap Localities API and Woosmap Distance API.